SamSungtwo
Active Level 4
I have my private DNS value configured for 1dot1dot1dot1.cloudflare-dns.com and the Samsung browser does not appear to acknowledge the use of DNS over TLS when tested using the cloudflare site https://1.1.1.1/help.

Does Samsung browser acknowledge the configuration of DNS over TLS?


11 Comments
CHMultimedia
Expert Level 5
For me, DoT works but not DoH. Might also depend on your ISP. Using S Internet as well

Also good choice to use this! Increases your privacy sharply.
Reply
Loading...
SamSungtwo
Active Level 4
DOT (DNS over TLS) does not work only with Samsung browser. The ISP does not matter as the the phone points directly to DOT or DOH provider.
Reply
Loading...
CHMultimedia
Expert Level 5
Well you are right that this issue shouldn't be caused by your ISP. But you are incorrect that S Internet does not work with DoT,as evidenced by this screenshot
Reply
Loading...
SamSungtwo
Active Level 4
I did not comment on S internet. As I have no ideas what it is.
This is the result with private DNS configured with cloudflare.
Reply
Loading...
CHMultimedia
Expert Level 5
S Internet is Samsung Internet... It's an abbreviation instead of always saying Samsung this, Samsung that... especially since all those apps used to be just called S this, S That (S Note, S Health...)
Reply
Loading...
SamSungtwo
Active Level 4
OK. I am using DNS 1.1.1.1 and I am not aware of any other options to correct the issue.
Reply
Loading...
CHMultimedia
Expert Level 5
Check if you have any firewall enabled that blocks ports 443 or 853
Reply
Loading...
SamSungtwo
Active Level 4
it appears there is a problem with Dot on certain networks. can you pay your screen capture including your AS number and name?
Reply
Loading...
SamSungtwo
Active Level 4
the port 443 and 853 are open to one.one.one.one and 1dot1dot1dot1.cloudflare-dns.com
Reply
Loading...