Highlighted
Active Level 1
So I got my Galaxy Buds+ today. I was so excited because I loved my OG Galaxy Buds. Unfortunately, when I tried pairing it my phone, the left bud just can't seem to connect.

Heard it was a common issue so I looked up some resolutions that worked for others. Didn't work with mine sadly. Still I'm not giving up, don't want the trouble of returning it or going to the service center yet. 

EDIT: Finally made it work 😂 Thanks to Samsung AU support.
7 Comments
Highlighted
Active Level 3
Do you have Galaxy Wearables Application? try to browse the settings and options in it.
Reply
Loading...
Highlighted
Active Level 1
hello, yes! I have the galaxy wearables app. Unfortunately, it couldn't detect the left bud as well initially. But it's all good now ! Was able to get help from Samsung AU chat support 😂
Reply
Loading...
Highlighted
Beginner Level 2
can you tell me how?
Reply
Loading...
Highlighted
Active Level 1
Hi, sorry for the late reply. Are you having the same problem? if so, have you tried charging it for a long time? sometimes one of the buds is extremely drained.
Reply
Loading...
Highlighted
Beginner Level 2
it is ok now yeah it is just drained... i just charge the drained bud piece without closing the case
Reply
Loading...
Highlighted
Beginner Level 2
Hello guys.. can you share me how did you fix it. I order may galaxy buds+ online and it just arrived today. But the left bud is not connected. I already tried other troubleshooting Ex. uninstall and install. But it did not fix it. Thank you in advance guys!
Reply
Loading...
Highlighted
Active Level 1
Hello, sorry for the late reply! have you tried charging the left bud alone in the case? sometimes it's just really drained, even though the LED indicator shows green
Reply
Loading...