Original topic:

My voice cuts off and on when I use WhatsApp and Signal. Everything else works fine.

(Topic created on: 05-24-2022 01:03 PM)
Ganbay
Active Level 2
Options
Galaxy A

I have tried turning the phone off and back on.  I have made sure the mic works properly. I have taken the sim card out and turned the phone back on.  I made sure all software was up to date.  Everything else works fine the texting the video and I xan hear everybody well.  Any advice?

 

0 Likes
24 Comments
RedDogRabbit
Expert Level 5
Options
Galaxy A

I don't use WhatsApp, but audio on Signal is terrible! Sounds like the audio is going through a yoyo.

I'll ask the person to call me back on a regular cell line. 

0 Likes
Helenna
Moderator
Moderator
Options
Galaxy A

Hi Members_E3ZGk46, usually we will notice a lag in whatsapp calls as it is VoIP calls.

It depends on the network speed and stability.

0 Likes
Ganbay
Active Level 2
Options
Galaxy A
That is not the issue. My spouse has no problems with her apps
0 Likes
RedDogRabbit
Expert Level 5
Options
Galaxy A

You can try Clearing Network Settings, but I know from my own experience that Signal Private Messenger at least, often sounds terrible.

Obviously BOTH WhatsApp & Signal rely on network connections, but I seriously doubt that it is a hardware problem on your device.

You could also try clearing cache and data for both apps. ⚠️ If you clear Data for Signal, make sure you have a backup & know the backup code, if you want to Restore previous conversations.

No idea about WhatsApp. 

0 Likes
Ganbay
Active Level 2
Options
Galaxy A
I appreciate your assistance. I will try these. I had cleared the cache from WhatsApp. I thought then it was limited to WhatsApp but I am having the same issue on Messenger and Signal. Is it something else in my settings? The cellphone works fine. This started a few days ago.
0 Likes
RedDogRabbit
Expert Level 5
Options
Galaxy A

Are you using WiFi Calling? You can try turning it off & see if it's better.

0 Likes
Ganbay
Active Level 2
Options
Galaxy A
No I am not.
0 Likes
RedDogRabbit
Expert Level 5
Options
Galaxy A

Well, you can try Booting into Recovery and wipe cache. See if that fixes the issue for you. 

1) Turn off the device & wait a few seconds. 
 
2) Press and hold the Volume Up key and the power button.
 
3) When the Android logo displays, release all keys.
 
4) Press the Volume down key to navigate and select "Wipe cache partition".
 
5) Press Power key to select. When the wipe cache partition is complete, Select Reboot System.
 
6) Press the Power key to restart the device.
Ganbay
Active Level 2
Options
Galaxy A
I tried doing this but I don't get the Android display. I shows Samsung and then my home screen.
0 Likes