melvin-25
Beginner Level 3
Options
Galaxy A
Samsung A32 4g July 2022 Update caused my phone to lag particularly when the refresh rate is set on 90 hz
0 Likes
3 Comments
Options
Galaxy A

Hi melvin-25,

We are glad to help you. Please select options below which are the best suited to resolve your problem after update.

1) Ensure that you have a strong wi-fi connection.

2) Make sure all Apps are updated in the Playstore and Galaxy Store.

3) Clear Cache

4) Sufficient memory space

4) Battery Health Check - Open Samsung Members

Click on the Get help option from the bottom of the screen and tap on Go to Phone Care.

Select Interactive checks.
Click on Battery in the top left-hand side corner.
Here, you can see information related to the battery of your Galaxy phone, such as battery power, Life, Capacity, and, Charging. In the case of battery life or battery health, you’ll get the following results:
Good
Normal

Hope it helps you out. Have a nice and safe days ahead!

0 Likes
Khaled75
Expert Level 5
Options
Galaxy A
Did you try these steps?

1) Ensure that you have a strong wifi.

2) Make sure all apps are updated in the Google Play Store and Galaxy Store.

3) Try wipe cache partition. Steps:
1. Turn off your phone.
2. Plug in the USB cable via PC or charger (in case its USB-C to USB-C).
3. Then press and hold Power and Volume up buttons.
4. Release the power button. When the recovery screen shows up, release the volume up button.
5. Navigate to and select Wipe cache partition (Volume up and down is for highlighting options and power is to select).
6. Navigate to and select Yes.
7. Press the power button to select Reboot system now.

4) Make sure you have sufficient memory space.

5) Battery Health Check - Go to Samsung Members > Get help or Support > Diagnostics or Samsung Members > Diagnostics. Tap on Battery. If it's Good or Normal, then the battery is still good. If it's Bad (highlighted in red), bring it to a Samsung Service Center to have it checked.
melvin-25
Beginner Level 3
Options
Galaxy A
I already fix the issue by switching the 90hz display off then I on it afterwards
0 Likes