Resolved! Solved

Original topic:

guys. my unlocked s10+ keeps on dropping my mobile signal. any solutions?

(Topic created on: 01-10-2021 04:26 PM)
657 Views
paone
Active Level 3
Options
Galaxy S
Please help with my galaxy s10 plus. Can't receive calls and text messages on time.
0 Likes

2 Solutions


Accepted Solutions
Solution
Jo3campy
Active Level 2
Galaxy S
mine did this so I ordered a new sim that was upgraded not really sure what was upgraded sim but that's what bell told me mine was an old version and it's been flawless and no more dropped signal

View solution in context

Solution
Halston
Moderator
Moderator
Options
Galaxy S

Hi paone

Welcome to the Samsung Members Community Canada. As you have performed Factory Reset and the issue persists. Please contact your carrier service provider and try to change the SIM. I hope it will work.

Get back to us with the result.

View solution in context

29 Comments
thebigguy86
Active Level 7
Galaxy S
try getting a new sim card
0 Likes
paone
Active Level 3
Galaxy S
is there any way to set manual apn settings?
0 Likes
thebigguy86
Active Level 7
Galaxy S
Only if you know your providers apn settings, try putting your sim card into a different unlocked phone, if it works then its your device
0 Likes
paone
Active Level 3
Galaxy S
Disabled my AWS LTE bands and everything works fine. Idk why my device switches to AWS LTE bands.
0 Likes
asifakberali
Active Level 8
Galaxy S
Yes. Which carrier you want the APN settings for? I can do some research and help you. I have my APN settings set manually on Chatr SIM since my Galaxy phone was originally from the US.
paone
Active Level 3
Galaxy S
hey Mine is CHATR too. how can I edit apn or manually set apn. please help. my s10+ drops cell signal all the time. thanks In advance
asifakberali
Active Level 8
Galaxy S
Ok here it is.. try this, leave the other settings as it is it you don't find them in the photo. I'll also give you a snapshot of my latest settings. I actually kept APN on its default settings, and Internet didn't work, so then I removed 'Mobile virtual operator something like that way in the end, and voila, Internet worked. make sure to disconnect yourself from your wifi router before u try these settings. Hope this helps. 👍

20210110_221937.jpg

20210110_222128.jpg

0 Likes
paone
Active Level 3
Galaxy S
how can I add apn settings. everything is greyed out. it doesn't let me add new apn settings.
0 Likes
asifakberali
Active Level 8
Galaxy S
You cannot add new APN profile? Ha. That's weird. How about altering the current profile. All I did was, remove the last virtual mobile operator field. Rest, I kept as it is. 👍
0 Likes