Original topic:

S23 Ultra WiFi "not connected to the internet"

(Topic created on: 03-02-2023 02:27 PM)
931 Views
Fuurinkazan
Beginner Level 3
Options
Galaxy S
I have been experiencing an issue that seems to be well documented online (Google "connected without internet s23 ultra" to see many hits on Reddit and news articles reporting it). The issue is: when connected to my WiFi 6 router, a TP Link Archer AX6000 (both on 2.4ghz and 5ghz SSIDs), intermittently I will be disconnected from the WiFi and connected to 5G/LTE mobile data or when that setting is turned off I get the error message "connected without internet" with "!" next to the WiFi icon. This issue can happen after 5 minutes or a few hours but happens in many different circumstances including streaming media to my device with YouTube or Spotify, using Chromecast, web browsing, or when I'm not using my phone and notice that I haven't received any messages in a while. This effects both my personal and work profiles. I have tried deleting my saved wifi info, looking for software updates (there are none), resetting my network settings and other steps. This has been ongoing since the day I received the device and no amount of resetting settings or deleting saved data seems to fix the problem for me or the dozens of other people complaining online. A software update was recently pushed OTA and I had hoped it would address the problem but it still is happening several times a day. 
4 Comments
Galaxy S

Hey Fuurinkazan, **bleep** to hear. I saw this story too. I guess if you log into your router, there's not options to change the WiFi protocol it's using?

0 Likes
RobertZ
Active Level 9
Galaxy S
Try disabling IPV6 on your router, reboot your router, then reboot your phone. See if that helps after your phone reconnects.
0 Likes
whips
Active Level 3
Galaxy S
In your phone wifi settings under MAC address type, is set to Randomized MAC? If so, change it to Phone MAC, it could be your MAC address changing that is causing intermittent disconnection from your router.
0 Likes
ophelix
Active Level 1
Galaxy S

i had the same issue with my zflip4. what finally worked for me after hours of trying different things:
1. settings
2. connections
3. more connection settings
4. private dns:
5. change it from “private dns provider hostname (my name used to be “dns.google”)” to “automatic”
i then tried reconnecting to the wifi and lo and behold it worked!

i hope this works for you?

0 Likes