cancel
Showing results for 
Search instead for 
Did you mean: 
Resolved! Solved

Original topic:

Samsung Galaxy S20 Ultra No Network Signal

(Topic created on: 09-10-2022 05:13 AM)
4857 Views
Iggyboi
Active Level 3
Options
Galaxy S
Hi Guys, anyone can help will be greatly, super duperly appreciated.

I have a S20 Ultra (obvious on my post on this platform). It was working great -- But the problem started which I'm not really sure when..but let me give you what brings my headache.

My phone at first dont have this kind of issue, but for sometime now its showing no network/signal and remain as it is..I did a lot of reasearch but cant find the help that can help.

Anyone experience the same? Whats causing the issue? Any recommended solution please.

I still love my phone and it still works fine -- But how to fix this?

Like literally, upon restart it will give you a few sec of network, but after your at your own.

Please help me
0 Likes
Resolved!
ProCo
Expert Level 4
Galaxy S
You need to select one sim for your device.
0 Likes
Iggyboi
Active Level 3
Galaxy S
What do you mean? Thanks
0 Likes
jamesrred
Expert Level 1
Galaxy S
When you go to Settings > Sim Card Status > Signal Strength, can you show me a screenshot of the page?
Iggyboi
Active Level 3
Galaxy S
Here it is.Screenshot_20220911-112638_Settings_3422_1662866798.jpgScreenshot_20220911-112648_Settings_3424_1662866808.jpg
jamesrred
Expert Level 1
Galaxy S
I have a worse signal strength than you, but I still do have a connection and can make calls. This could be a hardware issue with your antennas. Please have your phone checked at the nearest Service Center near you, or call the hotline #GALAXY to voice out your concerns.

https://www.samsung.com/ph/support/service-center/
Iggyboi
Active Level 3
Galaxy S
Ohh..what possibly caused the hardware issue? As far as I remember I dont experience this until I updated the software to 12.
0 Likes
butete
Expert Level 5
Galaxy S
any chance your on globe sim?
butete
Expert Level 5
Galaxy S
wipe cache partition, if did not fix it factory reset but be sure backup data
Iggyboi
Active Level 3
Galaxy S
Yes, Im using Globe on Sim 1 and Dito on Sim 2. Did your and @khaled75 recommendation wiping the cache partition. For a minute there I thought it works, I was very happy..But just after several minutes the issue returned and note that my other device (Note 10+) work just fine with the signal.

I already did factory reset before I posted it here and did not solve the problem. Im really facing the wall now.
butete
Expert Level 5
Galaxy S
mine worked after factory reset