Resolved! Solved

Original topic:

Sleep Mode Does Not Turn On Automatically | After One UI 5.0 Update

(Topic created on: 12-19-2022 11:44 AM)
10232 Views
raghav507
Active Level 3
Options
Galaxy Series

Hi there.

I have a Galaxy S22 smart phone.

Since it got updated to the One UI 5.0 a couple of months ago, the sleep mode has stopped working for me.

 

I have it set up in the Modes and Routines app and the clock app.

The time set is 9 PM in the night every day to 7 am in the next morning every day.

I have set it up to turn on the screen grey scale in between these times, with do not disturb turned on too.

 

Before the update, it worked fine - every day at 9 pm it would turn on and do not disturb would be active.

Now it does not turn on at all.

When I open the modes and routines app, and save the time again by clicking Done, it turns on.

If I don't open the app and click done on a given day, it does not turn on at all.

 

I have tried resetting all settings once and clearing cache etc. but it does not work at all.

Is anyone else facing this weird issue as well?

Please share your input.

 

Thanks.

2 Solutions


Accepted Solutions
Solution
user_393941
Beginner Level 2
Galaxy Series

Instead of using the pre-defined "sleep" mode I have created a mode called "My Night Mode" and deleted the sleep mode. So far it works flawless. Starts at right time, stops at right time. Phone goes to dark mode. DND is turned on. Battery saver turns on and off automatically. I am happy.

Also while deleting the "Sleep" mode I got a warning that all associated alarms in the clock app will also be deleted. So yes, there is definately a connection to the clock app somehow with the predefined sleep mode.

Maybe it tries to guess if you are sleeping according to movement of the phone or something. So it turns on according to that? But that is not what I want. I want my DND mode at a specific time. If I fall asleep earlier, people should be able to wake me. If I fall asleep later shame on me I wasted some sleeptime. A specific DND time is something I can communicate to my colleauges and family. Some random guessed sleep time not so much. (My phone sometimes just sits on the desk. Does not mean I am actually sleeping early. People should be able to reach me then.)

View solution in context

Solution
jushag
Beginner Level 2
Galaxy Series

For anyone still encountering this issue, this is what worked for me:

Settings -> Apps -> Modes and Routines -> Storage -> Clear data

This will delete any settings you have for "Sleep" (or any other) mode, meaning you'll have to re-set it back up. This re-setup process I believe is what fixed it for me, I had some lingering configuration that was preventing the schedule from being honored. After re-setting it back up it's worked flawlessly since.

View solution in context

0 Likes
36 Comments
raghav507
Active Level 3
Galaxy Series
I can share screenshots if required.
0 Likes
Galaxy Series
Show the screen shot how to setup
0 Likes
raghav507
Active Level 3
Galaxy Series
Here you go.
Screenshot_20221219_142733_Modes and Routines.jpg
0 Likes
Samsung_Ruby
Community Manager
Options
Galaxy Series

Hi raghav507, if you haven't already we recommend you update your software too the latest version, which should have been released recently. - Thanks, The Samsung Team

0 Likes
raghav507
Active Level 3
Galaxy Series
Hi there.
Thanks for your reply.
I have already done that and will do it again now.
The issue is still persisting.
luciferankon
Beginner Level 2
Galaxy Series

The last update I've is from November. When was this update released?

raghav507
Active Level 3
Galaxy Series
I have got the December update.
0 Likes
Rubias
Beginner Level 3
Galaxy Series

I have Samsung note 20, and I am also trying to find out if there's a fix... As far as I know, I have the latest update... And my phone does not go on bedtime mode automatically unless I go into settings. It worked perfectly before. Now it's pretty much garbage because I have to manually do it.

 

Galaxy Series

I am having the same problem. It also happened after the software update. 

It started working intermittently but now it does not turn off or on automatically for the times I set to turn on and off.