Resolved! Solved

Original topic:

Sleep Mode Does Not Turn On Automatically | After One UI 5.0 Update

(Topic created on: 01-31-2023 08:40 AM)
1059 Views
raghav507
Active Level 3
Options
Galaxy Series

Hi there.

I have a Galaxy S22 smart phone.

Since it got updated to the One UI 5.0 a couple of months ago, the sleep mode has stopped working for me.

 

I have it set up in the Modes and Routines app and the clock app.

The time set is 9 PM in the night every day to 7 am in the next morning every day.

I have set it up to turn on the screen grey scale in between these times, with do not disturb turned on too.

 

Before the update, it worked fine - every day at 9 pm it would turn on and do not disturb would be active.

Now it does not turn on at all.

When I open the modes and routines app, and save the time again by clicking Done, it turns on.

If I don't open the app and click done on a given day, it does not turn on at all.

 

I have tried resetting all settings once and clearing cache etc. but it does not work at all.

Is anyone else facing this weird issue as well?

Please share your input.

 

Thanks.

Tom33
Active Level 1
Galaxy Series

I totally agree with you, It's very weird. I also don't want the alarm turned on, but unfortunately, I need to have it on so the sleep mode works properly, I have the alarm sound turned off though.

raghav507
Active Level 3
Galaxy Series
Ohkk, that's a good idea to turn off the alarm sound, i will try that today.
0 Likes
Tom33
Active Level 1
Galaxy Series

The problem is that the alarm still goes on just without the sound and then I have missed alarm sitting there in notifications.

I hope it's not a deliberate design and Samsung will fix it.

raghav507
Active Level 3
Galaxy Series
Yes, I also noticed that this morning.
This is a classic case of breaking something which was already working fine.

Btw, I have got a reply from Samsung mentioning about the update for this month. They say it might fix this problem.
Let's keep an eye on that.
Galaxy Series

My S22 Ultra continues to enter sleep mode 15 to 30 minutes before the set time and it never comes up out of sleep mode unless I do it manually.

My wife has an S22 and hers goes into sleep mode at the set time and comes out of sleep mode automatically.

Other than hers not being an Ultra, I wonder if there is an app that is interfering with mine.

raghav507
Active Level 3
Galaxy Series
Update - i installed the samsung official software update on Saturday morning.
That day the sleep mode worked fine, probably due to restart of the phone.
But next day, it didn't work by itself. :(
I had to open the clock app in the scheduled hours and the moment i did that, the sleep mode turned on.
It is super annoying.
Galaxy Series

I'm facing the same problem with S22+ and even after January 2023 patch, the bedtime mode simply doesn't activate automatically. Pretty annoying. C'mon Samsung! 

A3_
Beginner Level 2
Galaxy Series

i have the same issue with my S21 ultra

 

raghav507
Active Level 3
Galaxy Series

Update - I am testing various combinations and possibilities etc. but the issue still stands.

 

I have been able to figure out that clock app has something to do with this sleep mode.

Whenever the sleep mode is not turned on as scheduled, all I have to do is open the clock app, in the alarms view.

As soon as it opens the sleep mode turns on as scheduled.

I will share this information with Samsung NZ and will update here if I get any response.

OriginalPaladin
Beginner Level 4
Galaxy Series

I greatly appreciate @Tom33's work-around!  I'm going to give that a try tonight with the "Wake-up alarm" turned on and the the Sound, Vibration, and Snooze for it turned off.

I'm wondering, has anyone also tried setting the Modes and Routines app's Battery settings to "Unrestricted" directly in the Android Settings app and seen if that works?  I know that Tasker tells you if you don't do that, it will not work properly.