Original topic:

Saving photos and videos only in work OneDrive and not personal OneDrive

(Topic created on: 05-30-2021 06:43 PM)
Sabsies
Active Level 1
Options
Others
I've done a lot of googling and checked all the settings I could find. But Samsung gallery still creates a media folder and syncs my camera pics and vids in my personal OneDrive as well as work OneDrive. In the gallery app I said to save camera to my work one And for media syncing, in settings -> accounts and backup, then to each OneDrive profiles, media syncing is only on for my work OneDrive. But Samsung gallery is still saving my camera upload in both OneDrive accounts, causing duplication. Anyone know a workaround? I've probably spent 3 hours so far trying to remedy this.
5 Comments
Vic20
Active Level 10
Options
Others
Did you by any chance link Gallery to One Drive? If so, unlink the accounts. To unlink accounts, go into Settings>Accounts and backup>Accounts. Select your Samsung account and go into Apps and services>Connected services. Select Microsoft (or OneDrive; can't remember now what it was listed as) and choose disconnect. Then go into OneDrive settings and turn on camera upload. Also in Camera Upload option, select your personal account for sync.

I have 1 personal and 2 business accounts. I do not have this issue. But I also removed the Gallery/One Drive linked accounts in the past as I found it frustratingly backwards. You can also see the message I get when accessing my work account reference videos/photos. It could be a bug with Samsung Gallery and One Drive linked accounts though. I can't say for sure though as I refuse to link them.Screenshot_20210530-201038_OneDrive_23517.jpgScreenshot_20210530-200515_OneDrive_23516.jpgScreenshot_20210530-195942_OneDrive_23515.jpg
0 Likes
Sabsies
Active Level 1
Options
Others
Yes, my camera upload account is my work account. Also I had to typo in my original post title, I meant to save in my work account and not in my personal account.

The order of the settings unlink is a different, I am on a s10e on the latest one ui version. Took me a bit to go through, it was accounts and backups -> manage accounts -> samsung email -> my profile -> linked accounts -> Microsoft -> unlink. I just tried this and took a photo. I deleted the Samsung gallery folder in my personal OneDrive where it would save camera uploads. The picture saved to my work OneDrive as expected, and no sign in my personal OneDrive. It also didn't bring up the notification of "can't sync with OneDrive" for my personal OneDrive, after I deleted the Samsung gallery synced folder in my personal one. That notification was annoying before doing this. So it seems to work based on this little test. If it doesn't work in the future I'll update this post. Thanks for your help, I appreciate it. This was harder than it should be.
0 Likes
Vic20
Active Level 10
Options
Others
Good to hear. Yeah I remember that notification was annoying. Thanks for update with OneUI 3. My instructions were based off OneUI 2. It's been a while I unlinked the accounts and going off an old post I made earlier about it.
0 Likes
Halston
Moderator
Moderator
Options
Others

Hey Sabsies,
Is your problem got resolved by following the suggestions provided by Vic20?

Thank you Vic20 for your information.

0 Likes
Sabsies
Active Level 1
Options
Others
Yup, so far so good.
0 Likes