Active Level 5
Should still be named bedtime mode because all the searches take you to putting computer or TV's into sleep mode. 

Issue = watch sleep mode not overridden by phone setting and doesn't automatically sync 

OK for future reference in case anyone else has this issue.
● you need to go to settings on the watch and tap advanced features, sleep mode 

● turn off the (turn on as scheduled) if its set and then tap set on phone.

● after you set it on the phone then you have to go back to your watch check to see if it's on the correct schedule

● if not turn off the (turn on as scheduled) option and then back on. 

Because the phone setting doesn't override the watch setting one should be able to set either and have it sync or at least ask if you want them the same