Original topic:

S22 Ultra Wifi connected but no interenet access issue

(Topic created on: 10-20-2022 06:32 PM)
397 Views
Members_pGKEcpX
Beginner Level 2
Options
Galaxy S

I have the same issue as to lot of others for my Samsung S22 Ultra with wifi showing connected but no internet access.

At home, we have a wifi 6 router and my S22 Ultra connects to the 5Ghz. Every day after I get home and my S22 Ultra showing ! sign beside the wifi icon, then I have to disable wifi and enable wifi to have it work.

I have searched online and none of the solutions really fix my problem, e.g change IP from DHCP to Static.

Will Samsung provide an update or solution to this? Don't seem to get anything from Samsung community either. Disappointed with a Flagship phone with such an annoying connection issue.

0 Likes
6 Comments
Galaxy S
Is it just your home wifi or public wifi as well? If I have ever had ! showup on my S22Ultra at home then I turn my router off and it fixes it. Also try the diagnostics test
Galaxy S
What I do as we have so many people using wifi. Unplug the modem, left it for 5 minute. No need to turn off modem but unplug. It should solve the problems
0 Likes
Galaxy S
The same with smart TV
0 Likes
Caleb82
Beginner Level 3
Galaxy S
I've got same issue on s21 ultra 5g model. It's quite frustrating to say the least. And still no answers.
0 Likes
Gari123
Beginner Level 2
Galaxy S
I hate my S22 Ultra. It keep disconnecting itself from my home Wi-Fi. Tried everything but nothing works. Worst phone I ever bought.
Gari123
Beginner Level 2
Galaxy S
I think I have identified where the problem is. Samsung devices cannot identify that different wifi beacons are in the same network. I turned off my other wifi 6 beacon and I have not yet had any problems with connectivity issues. The downside is that now I have limited wifi range. Not cool Samsung considering how much your gadget costs