Resolved! Solved

Original topic:

Sleep Mode Does Not Turn On Automatically | After One UI 5.0 Update

(Topic created on: 02-12-2023 12:18 PM)
4922 Views
raghav507
Active Level 3
Options
Galaxy S

Hi there.

I have a Galaxy S22 smart phone.

Since it got updated to the One UI 5.0 a couple of months ago, the sleep mode has stopped working for me.

 

I have it set up in the Modes and Routines app and the clock app.

The time set is 9 PM in the night every day to 7 am in the next morning every day.

I have set it up to turn on the screen grey scale in between these times, with do not disturb turned on too.

 

Before the update, it worked fine - every day at 9 pm it would turn on and do not disturb would be active.

Now it does not turn on at all.

When I open the modes and routines app, and save the time again by clicking Done, it turns on.

If I don't open the app and click done on a given day, it does not turn on at all.

 

I have tried resetting all settings once and clearing cache etc. but it does not work at all.

Is anyone else facing this weird issue as well?

Please share your input.

 

Thanks.

36 Comments
Solution
user_393941
Beginner Level 2
Galaxy S

Instead of using the pre-defined "sleep" mode I have created a mode called "My Night Mode" and deleted the sleep mode. So far it works flawless. Starts at right time, stops at right time. Phone goes to dark mode. DND is turned on. Battery saver turns on and off automatically. I am happy.

Also while deleting the "Sleep" mode I got a warning that all associated alarms in the clock app will also be deleted. So yes, there is definately a connection to the clock app somehow with the predefined sleep mode.

Maybe it tries to guess if you are sleeping according to movement of the phone or something. So it turns on according to that? But that is not what I want. I want my DND mode at a specific time. If I fall asleep earlier, people should be able to wake me. If I fall asleep later shame on me I wasted some sleeptime. A specific DND time is something I can communicate to my colleauges and family. Some random guessed sleep time not so much. (My phone sometimes just sits on the desk. Does not mean I am actually sleeping early. People should be able to reach me then.)

raghav507
Active Level 3
Galaxy S
That's a great idea, thanks for sharing it, i will try this today onwards for some days and will see if it works successfully. :)
0 Likes
raghav507
Active Level 3
Galaxy S

I have tried this solution and it works for me. :)

It has worked for 2 days in a row without fail and I am testing it as an ongoing process.

I will post more updates here to share my feedback.

So far so good though.

0 Likes
raghav507
Active Level 3
Galaxy S
I have been testing the solution given by user_393941.
It has been working fine for me now.
I have accepted this one as the solution and have marked the query as solved.
Hope it works fien for you all as well.
0 Likes
Galaxy S

Installed the latest update and sleep mode is now working as it is supposed to.

raghav507
Active Level 3
Galaxy S
That's great to know, let me test that one today onwards.
I will post updates as I go on.
0 Likes
Solution
jushag
Beginner Level 2
Galaxy S

For anyone still encountering this issue, this is what worked for me:

Settings -> Apps -> Modes and Routines -> Storage -> Clear data

This will delete any settings you have for "Sleep" (or any other) mode, meaning you'll have to re-set it back up. This re-setup process I believe is what fixed it for me, I had some lingering configuration that was preventing the schedule from being honored. After re-setting it back up it's worked flawlessly since.

0 Likes