cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S20FE not fast charging

(Topic created on: 09-04-2023 07:45 AM)
329 Views
Melai023
Active Level 1
Options
Galaxy S
Charging became slow after I restarted my device yesterday. Before that, fast charging was working fine. All toggles in "More battery settings" are enabled.

Will try to restart now then see if it is fast charging when turned off. 

UPDATE: Phone is fast charging when turned off. Went up to 75-77% in less than 2 minutes during down time. 

Problem persisted after it was turned on. Notification says "Charging" only. Tried to unplug and replug and notif briefly says "Fast Charging" then immediately returns to "Charging."


5 Comments
TeamGalaxyDD
Moderator
Moderator
Options
Galaxy S

Hey Melai023,

Thanks for reaching out.

By any chance, have you turned off your fast charging from your settings?

Please check Settings > Battery and device care > Battery > More battery settings > Turn on fast charging. 

0 Likes
Melai023
Active Level 1
Galaxy S
I didn't turn it off. All toggle buttons for fast charging are enabled.Screenshot_20230905_102244_Device care.jpg
TeamGalaxyDD
Moderator
Moderator
Options
Galaxy S

Yup, thanks for the update.

Right now, here's a few things you can do:

1. Try a different cord

2. Try a different charging brick

3. Run the diagnostics tool from your Samsung Members app and see if your charging port has issues. Have a charger on hand. 

If it turns out that there is damage to your charging port, you might have to bring it to your nearest Samsung Service Center. Should you need an appointment, you may book one directly from the Samsung Members app or by calling #GALAXY. :) 

0 Likes
Melai023
Active Level 1
Galaxy S
Diagnostics says it's fast charging. Notification says "Charging."Screenshot_20230905_190458_Samsung Members.jpgScreenshot_20230905_190512_Samsung Members.jpg
0 Likes
TeamGalaxyDD
Moderator
Moderator
Options
Galaxy S

Ok hold on, I misread. You've already been to more battery settings -- could the problem be with your charger cord? 

 

0 Likes