Original topic:

I need helpp

(Topic created on: 08-12-2022 10:47 AM)
238 Views
joojb
Active Level 3
Options
Galaxy S
My s22 keeps getting hotter and hotter even when it is not charging. Didnt play games with it and i just scrolled some social media. No third party apps all download from play store, cleared background,optimised device already, didnt open any other useless features. Just turned on wifi, bluetooth only.
3 Comments
scinex
Expert Level 4
Galaxy S
I did some testing before and maybe this might help.
Go to developer options and scroll down to 'background process limit' . Change the default setting to 'no background processes'.
I've tried using this setting for a week and to be honest, the phone never got hot at all. Please be aware that if you restart the phone, the setting will go back to default, which is 'standard limit'.
Hope this helps. All the best!Screenshot_20220812-105005_Settings_36108_1660272606.jpg
GunasamssYT
Expert Level 5
Galaxy S
This is happen when you are using the 120hz your phone might get some heat. I'm not fully sure tho because I don't have the s22 so yeah. But try changing the frame rate to the standard one and see if it's lowering the heat!
EddieCS
Active Level 6
Galaxy S
Hard to determine what causes your heating issue. Maybe background apps running, maybe high display brightness due to ambient, or bad processor chip lottery.

An advice to you is to set most if not all apps into Sleeping mode or Deep Sleep mode in "Settings->Battery->Background Usage Limits". 120Hz or not is up to you since I rather use 120Hz smoothness than to run at 60Hz, knowing the SOT battery life is very very similar on my S22 Ultra for I had my first 4 months of running full time in power saving mode and now full time 120Hz with no Power Saving.

Secondly, you could install Nice Lock from playstore then from within Nice Lock, get Good Guardian's Thermal Guardian and Battery Guardian installed from Apkmirror website. Setup settings within those two apps to your liking and it may lower ur heat.
0 Likes