Original topic:

Tab S6 S Pen Disconnection Issue

(Topic created on: 10-27-2022 11:54 AM)
416 Views
Kevin1015
Active Level 1
Options
Tablets
My S Pen keeps getting disconnected from my Tab S6. At first when this issue happened, I was still able to reconnect it after a few tries even if it takes a while. After that though, it just disconnects again and when I try to reconnect it, it takes a long time and still won't connect. I've already sent 3 error reports and followed the steps given to me by a member of the Samsung team, yet nothing is working.
Anyone else have or had this issue?
7 Comments
Tablets
Hmm I wonder if the battery on the s pen is dead? You may have to replace it?
Widow-Hunter
Active Level 7
Tablets
I have the Tab S8,

Try rebooting the Tab and reconnecting the pen after it's full booted
Check for any firmware update for the S-pen

Pretty much I can think of anything but a dead one
Troubadour
Active Level 10
Tablets
Try going to Settings and search for Permissions for the pen. If it has the options between always on, only when connected, etc. try always on. Also Google the problem because frequently Google has more solutions. If you find a solution please advise here as this will help others.
0 Likes
Troubadour
Active Level 10
Tablets
Also https://www.samsung.com/latin_en/support/mobile-devices/what-to-do-if-your-s-pen-is-often-disconnect...
Another solution also suggested turning off pairing and reconnecting pairing more than once.
0 Likes
SamsungLaura
Moderator
Moderator
Options
Tablets

Hi @Kevin1015, thanks for reaching out. I've contacted the error reports team regarding your report and they have confirmed your error report is currently with our research and development team for analysis. Once this has been complete, our team will reach out with further updates.

0 Likes
Baringup
Beginner Level 3
Tablets
So, is there an answer to this yet as I am having the same issue with my S pen now
0 Likes
Kevin1015
Active Level 1
Tablets
It might've actually been a hardware problem in my S pen, so they just sent me a new one & it works fine.