Original topic:

Do Not Disturb Exceptions Disappear

(Topic created on: 07-09-2023 03:57 AM)
382 Views
NewToSamsung
Active Level 4
Options
Galaxy S
For the last little while, the exceptions I put in for Do Not Disturb are disappearing. I first thought I was doing something to cause it. But I have checked later in a day and the exception is still there. In one case I even checked the next day and it was still there. Then suddenly, **bleep**, it is gone and I am not getting message notifications from the person in the exceptions when the phone is in Do Not Disturb mode. Check the exceptions and the person is missing. 

The phone is a Galaxy S23 Ultra running Android 13, One UI 5.1. 

Does any one have any idea what is happening?
16 Comments
Perma1
Active Level 1
Galaxy S
I haven't tried it recently. In order to have some of my work contacts at the top of my phone dialer contact list, I've added them to my favorites, but I don't want them bypassing the "do not disturb". This doesn't address the problem of this new feature not working!
Try running a schedule and add a contact then see if the contact remains after the schedule has run.
0 Likes
IanOz
Beginner Level 3
Galaxy S

I have the exact same problem. I add 2 family members I am emergency contact for answer always and they randomly disappears from the Do not Disturb call and message contact allowed list. Sometimes after hours other times it works for days.

If I use Calls>favourite contacts only that setting stays on but I don't want all my favourites waking me.  

This seems to be a very specific bug that only affects individual contacts added to the top of the calls and messages screen. 

The only work around I have found is to add only emergency contacts to favourite but that gets annoying very fast. 

I keep hoping minor updates will fix but they have not. 

0 Likes
Perma1
Active Level 1
Galaxy S
See if you have repeat callers enabled, try disabling it. See my post in this thread.
https://us.community.samsung.com/t5/Galaxy-S23/Do-Not-Disturb-exceptions-not-working-on-S23-Ultra-An...
0 Likes
NewToSamsung
Active Level 4
Galaxy S
I, unfortunately, have to allow all calls through Do Not Disturb. That automatically enables repeat callers. Thank you for your suggestion though.
0 Likes
Perma1
Active Level 1
Galaxy S
Try using the Do not disturb set through the "Sleep" "Mode" , -Settings -Modes and Routines -Modes -Sleep -Do not disturb. It's nearly the same screen. I've had it run two schedules, week and weekend, for about a week and it is still working. Fingers crossed...
0 Likes
NewToSamsung
Active Level 4
Galaxy S
Thank you for the suggestion. I had to add the sleep mode. I haven't added a schedule as I need to enable it when I head for bed (which is not very scheduled). But I have added the exceptions in the sleep mode, and I'll see if they stick. Once again, Thank you.
0 Likes
NewToSamsung
Active Level 4
Galaxy S
For whatever reason, the Do Not Disturb exceptions are no longer disappearing. I upgraded to OneUI 6 as soon as it was available in December (15th?). However, the exceptions were still disappearing. Sometime around the 25th they stuck and haven't disappeared since.
0 Likes