Highlighted
Beginner Level 2
I wasnt able to update my game launcher, it says doesnt compatible. I have galaxy note 10+
5 Comments
Highlighted
Expert Level 3
works for me , i click on the application and it ask me to accept conditions and that's it...
i also have a Note 10+
Reply
Loading...
Highlighted
Expert Level 5
Maybe try Clearing Cache & Data for the Game Launcher & try again 🐧
Reply
Loading...
Highlighted
Beginner Level 2
Reply
Loading...
Highlighted
Expert Level 5
Are you still having trouble updating after Cleaning Cache & Data for the app?
Reply
Loading...
Highlighted
Beginner Level 2
nope I uninstalled and reinstalled and it works thanks everyone
Reply
Loading...