Original topic:

S20 FA 5G VERY slow data download speeds

(Topic created on: 06-24-2022 08:25 PM)
Sabsung
Active Level 3
Options
Galaxy S
Hi all.   My S20 FA 5G is fine when connected to wifi but when I use the 5G download speeds I get 1 Mbps download and 30 Mbps upload speeds.   I've been on the phone with my provider Bell for hours, they've sent me a new SIM card to no avail.

Anyone here experiencing very slow 5G download speeds? Anyone find a fix to this?

Thanks for your time.
12 Comments
RedDogRabbit
Expert Level 5
Options
Galaxy S

How are you measuring your Data Speeds, Ookla?

Cellular Data Speeds can be affected by a variety of factors. Location, Network Traffic etc. Are you experiencing poor Data speeds everywhere you are, or just in one location? 

You could also ask Bell to Reset your Network connection. You could also reset your network connection on your end as well (not sure if there's a real difference between the two).

Other than that, there's not much else you can do. 

I'm sure that someone will suggest that you Boot into Recovery & Wipe Cache.. but meh, I doubt that will do much. 

 

Axton
Moderator
Moderator
Options
Galaxy S

Hi, we would like to inform you that The mobile data speed depends on the network availability and the carrier preferences.
We suggest you test the speeds in different locations.
Or If the phone is unlocked, you can use a different carrier sim card to test the speed.

RedDogRabbit
Expert Level 5
Options
Galaxy S

Since December 2017, ALL Canadian Cell phones are Carrier Unlocked. 

0 Likes
Sabsung
Active Level 3
Options
Galaxy S
Hi. Thanks for your suggestions. This has been going on for months so at many different locations around town. Bell sent me a new SIM card this week, no change. I'm starting to think it's the phone. I'm a techy and couldn't wait to buy a 5G phone. Little did I know it would be slower than my old Pixel running on LTE.
0 Likes
Sabsung
Active Level 3
Options
Galaxy S
I've tried the Google speed test, the Bell official test that they asked me to use and I just downloaded the Ookla app. Same thing. It happens everywhere. Ironically enough here in Montreal I was at a show in the Bell Center a few months ago and my daughter and I tested our phones there. Her iPhone with Telus was at over 400 Mbps, I was at a speedy 20 🙄.
We have a Samsung store in Town I will go see if they can figure something out. I thought of doing a Master reset and may try that first.
Thanks for your reply.
RedDogRabbit
Expert Level 5
Options
Galaxy S

A Factory Reset wouldn't hurt, you could also try Booting into Safe Mode, just to see if there's a 3rd party app causing the issue. 

Yeah those are shockingly dismal speeds you have on your device. 

Axton
Moderator
Moderator
Options
Galaxy S

Hi, can you run your phone in Safe Mode, create a folder with shortcuts, and restart the phone to see if the folders disappear? To enter Safe Mode, please perform the following:

First, completely power off the phone >> Then, power on the phone and when the Samsung logo appears, press and hold down the Volume down key. If done correctly, "Safe Mode" will display on the bottom left corner of the screen.
If
" Safe Mode" does not appear, repeat the steps above. Once you are in Safe Mode, you can remove the third-party app that is causing issues on your phone >> To exit Safe Mode, simply restart your phone and it will reboot normally. 
Please keep us posted.

Sabsung
Active Level 3
Options
Galaxy S
RedDogRabbit suggested Safe Mode yesterday. I tried that without the folder shortcuts you are suggesting and the speeds didn't change. For the record I've tested the speeds at different parts of town (full 5G coverage in Montreal) and the highest I've ever seen is 40 Mbps download and like 8 download.
This morning I realized my sister in law purchased the exact same phone a few months ago. She uses a different provider so she tested it for me. She got 14 Mbps download. I'm starting to think this phone is 5G only in name. Very disappointing.

Any of you using this exact phone?? Samsung Galaxy S20 FA 5G??
0 Likes
RedDogRabbit
Expert Level 5
Options
Galaxy S

I really don't think, that the speed issue (lack thereof), is a model specific problem.

It's going back a while, but I think that my ancient Skyrocket got better speeds on plain old LTE.

Your Carrier, Bell boasts about having the fastest 5G network in Canada, but you aren't seeing it.

You can open the Samsung Members app & Click on "Support" & Diagnostics > View Tests, then see if you get any error messages running the "Mobile Network" test 

Unless it's a hardware issue specific to your device, ie: something is broken, the only two things left are a Factory Reset, and if that doesn't work, visit a Samsung Service center (my confidence in them is *undetermined* lol).

But reading reviews from Android Authority, GSM Arena etc, there's no mention of a universal issue with your device's data speeds.. 

If it'd be me, I'd backup with Smart Switch & Factory Reset as the 2nd last resort. Service center being the last.

If you Factory Reset, test the data speeds BEFORE you restore your device!!