Original topic:

S23 Ultra - wifi calling Bell Mobility option missing

(Topic created on: 03-07-2023 05:04 PM)
2830 Views
speedbird
Active Level 1
Options
Galaxy S

I purchased the S23 Ultra direct from Samsung Canada (pre-order). I have wifi calling included in my Bell plan and did a SIM swap to the new phone but the wifi calling option is "missing" as an option on the phone. I've had the phone 3 weeks.

I have followed many forum posts (removing SIM, restarting phone, re-inserting SIM, resetting network settings etc.) but the option to turn wifi calling on never appears.

I have confirmed with Bell that it is provisioned on my account (and I see it on mybell account). I did not change my plans when switching phones either.

I have a ticket open with Bell back-office but they insist it isn't on their end.

Any suggestions? Attached is screenshot of what I see in the Phone>Menu. I expect to see it grouped by the Voice Mail.

Thanks.

Screenshot_20230307_195254_Call settings.jpg

 

Solution:

Well I have self resolved the problem. I ended up switching from Physical SIM to eSIM and as soon as I did that and restarted the wifi calling options appeared and I could set it up.

I hope this might help others.

11 Comments
GG2
Expert Level 3
Galaxy S
Did you check in your quick panel settings if it's turned on ?

Screenshot_20230307_214313_Samsung Members_1000002475_1678243434.jpg
0 Likes
speedbird
Active Level 1
Galaxy S
I did and I don't have that as an option either. It doesn't even appear as a button I can add.
0 Likes
GG2
Expert Level 3
Galaxy S
Did you check through your dialer settings if it's there ? Dialer > 3 dots top right > settings > wifi calling toggle on/off ?
0 Likes
speedbird
Active Level 1
Galaxy S
Thanks but already tried that :( The screenshot in the original post is from the phone Dialer app settings.
0 Likes
GG2
Expert Level 3
Galaxy S
Yeah sorry, realized that after posting. After everything you tried, i would call back my carrier and ask them to reset (refresh) my account as it seems to me it's on their end even though they say otherwise, unless you want to do a full back up and factory reset as a last resort.
0 Likes
Helenna
Moderator
Moderator
Options
Galaxy S

Hi, as suggested by GG2 you may need to call to your carrier and ask them to reset you account.

If that doesn't work, unfortunately factory reset might be the last option to fix the problem.

Please perform back up and factory reset by following the steps in the given links.

https://www.samsung.com/ca/support/mobile-devices/galaxy-phone-back-up-and-restore-data/

https://www.samsung.com/ca/support/mobile-devices/galaxy-phone-perform-a-factory-reset/

0 Likes
GG2
Expert Level 3
Galaxy S
He's had the phone for 3 weeks.
0 Likes
speedbird
Active Level 1
Galaxy S

Well I have self resolved the problem. I ended up switching from Physical SIM to eSIM and as soon as I did that and restarted the wifi calling options appeared and I could set it up.

I hope this might help others.

Thanks to those that responded.

0 Likes
xjChick
Beginner Level 2
Galaxy S
Have the same issue myself. Nothing is working. Ill look into an esim.
0 Likes