Original topic:

Samsung Galaxy Tablet A9 LTE does slow charging and not showing any battery status.

(Topic created on: 05-31-2024 06:19 PM)
182 Views
Members_NvHtqT0
Beginner Level 2
Options
Tablets

 I got Galaxy Tablet A9 LTE, and it does not show the charging status. I already tried wipe cache partition, clear usb settings cache, repair apps, change usb cable, change power adapter, but no solution. When it is plugged, the battery will charge even slowly, but it really does take a really long time to fully charge. Hence, the battery status still not showing if it charging or not. I tried plugin usb cable to my pc too, but nothing works. Looks like the usb port might have been broken out of the box or software issues at the really beginning. At this time, i really think Samsung start to losing fight with its competitor. Any suggestion on this? This thing was bugging my mind since i got it as a brand new and it broken out of the box after i finish doing Smart Switch. Last time, my Galaxy Note 9 getting dead LCD after software update, and the technician told me that it might died due to overheat during updating process. And now the second time i bought a brand new Tab, the USB have issues like this on the very first hand. This is so frustrating.

1 Comment
Helenna
Moderator
Moderator
Options
Tablets

Hi, we are sorry to hear this issue from you and appreciate your efforts in performing all the possible troubleshooting steps to solve the issue.

Unfortunately, nothing works the Tab need to be evaluated by a certified technician. Please visit a Samsung authorized service center to have your device inspected in person, to get it fixed.

To know the nearest Samsung authorized service center, please visit the link given below. https://www.samsung.com/ca/support/service-center/ 

Thank you. 

0 Likes