Original topic:

Bluetooth switching while on phone calls

(Topic created on: 10-26-2021 09:02 PM)
mrigger3500
Active Level 1
Options
Galaxy S
My s21 ultra wants to connect to any of my bluetooth devices that it sees.
I use a headset all day talking to business associates but every time my phone sees any of my other blutooth devices it switches causing me to lose the call. lots of time it's when my wife comes home from work and her phone isn't connected to the cars bluetooth but mine does as she enters the driveway causing her to be confused as a random person is talking to her unexpectadly
11 Comments
Galaxy S
I remembered my Dad's car has the setting for not autoconnect (Toyota RAV4) . But not sure the other bluetooth devices. Maybe take a look at your car bluetooth settings?

I think Android or Samsung should implement autoconnect settings for devices. I can now see the problems if you have so many blue devices connect and disconnect while they are on all the time.
Georgine
Moderator
Moderator
Options
Galaxy S

Hi, Welcome to the Samsung Members Community Canada. Please perform the reset Network Settings on your device and check if it works fine.

Go to Settings>> General Management>>Reset>>Reset Network Settings>>Reset settings.

This will reset all network settings, including those for Wi-Fi, Mobile Data, Bluetooth. Restart the mobile if necessary and check if it works.

0 Likes
mrigger3500
Active Level 1
Galaxy S
I have reset everything my phone is only 2 weeks old! Samsung needs to develop some software that alerts you if another bluetooth network becomes available before switching.
Have the ability to select priority devices and an alert that pops up asking if you would like to switch. I have connected my devices in the order that I use them in headset first then truck but it still just connects to the truck instead of staying connected to the headset
0 Likes
OmarKhalid
Beginner Level 2
Galaxy S

I have the same issue and its really annoying and I tried so many ways but no use 

0 Likes
mrigger3500
Active Level 1
Galaxy S
All they need is a notification asking if you want to connect! I don't think it would be that hard
0 Likes
Georgine
Moderator
Moderator
Options
Galaxy S

Hi, please perform the below settings. Open settings>>search for bluetooth>>open Bluetooth settings>>select individual devices and disable auto-connect.

0 Likes
mrigger3500
Active Level 1
Galaxy S
I Might be having a slow brain day but I can't seem to find any Bluetooth settings that have auto connect toggles
0 Likes
Georgine
Moderator
Moderator
Options
Galaxy S

Hi, we suggest you to backup and reset. Here are the steps to backup your data: Backup from Samsung account--Apps > Settings > Cloud > Backup > Select the data > Back up now.

Backup from Google account--Apps > Settings > Backup and reset.

Here are the steps for factory reset, settings>>General management>>Reset>>Factory data reset>>Scroll down to the bottom and tap on Reset>> Delete All.

0 Likes
Tqpmtech
Beginner Level 2
Galaxy S

Backing up and resetting does not resolve the issue.   It only removed all Bluetooth devices,  after repairing them the same issue is present,  even on s21.

 

It's really not a hard request.   Just don't auto switch.   LG doesn't have this issue,  and it is very annoying.  To the extent that this may very well be my last Samsung phone, and I may go back to LG.  Fix it,  provide a solution.   If LG can do it with 1/2 the market share of Samsung,  I don't think it should be hard. 

0 Likes