Original topic:

Do Not Disturb Exceptions Disappear

(Topic created on: 08-01-2023 08:27 PM)
194 Views
NewToSamsung
Active Level 4
Options
Galaxy S
For the last little while, the exceptions I put in for Do Not Disturb are disappearing. I first thought I was doing something to cause it. But I have checked later in a day and the exception is still there. In one case I even checked the next day and it was still there. Then suddenly, **bleep**, it is gone and I am not getting message notifications from the person in the exceptions when the phone is in Do Not Disturb mode. Check the exceptions and the person is missing. 

The phone is a Galaxy S23 Ultra running Android 13, One UI 5.1. 

Does any one have any idea what is happening?
16 Comments
RedDogRabbit
Expert Level 5
Galaxy S

Screenshot_20230709_090523_Settings.jpg

Can you post a screen shot of your DND screen? 

This is mine:

Screenshot_20230709_090347_Settings.jpg

0 Likes
NewToSamsung
Active Level 4
Galaxy S
As per your request1688908407575_1688908407568_0.jpg1688908434229_1688908434225_0.jpg
0 Likes
NewToSamsung
Active Level 4
Galaxy S
Does no one have any ideas? Perhaps a moderator can shed some light. It is really getting annoying.
RedDogRabbit
Expert Level 5
Galaxy S

Moderators generally don't have much technical knowledge or experience. 

Here's a few things that you can try:

  • Boot into Recovery & Wipe Cache. See if that fixes the issue for you? 
  • Boot into Safe Mode & wait for one cycle of Do Not Disturb to start and end. See if DND Exceptions are still there? 
  • Backup your device with Smart Switch & Factory Reset. 

If none of the suggestions work, Open the Samsung Members app & Click on Support & Scroll down to error reports & send the error report to Samsung. See if they reply to you with anything useful. 

 

NewToSamsung
Active Level 4
Galaxy S
I have done the first and second suggestions. I am holding off on the third until after the August security patch rolls out as from memory this only started happening after the June or July security patch.
0 Likes
Perma1
Active Level 1
Galaxy S

I'm having the same problem. Restarting the phone doesn't seem to affect it, the allowed contacts are still there, but after some days or possibly weeks the allowed contacts get removed. I followed this post for the same problem. 

https://us.community.samsung.com/t5/Galaxy-S21/Do-Not-Disturb-Contact-Deletion/m-p/2591529/highlight...

I rebooted into recovery mode and wiped the cache partition and optimized the apps. I'll have to wait and see if it works. I have 2 schedules set, one for week days and one for weekends. The contacts are also favorites, but the option to allow all favorites is off as I don't want all my favorites to bypass "do not disturb".

0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

Are you also adding Contacts to the exception for DND, using the "+" in Do Not Disturb? 

I've only ever just used Favourite Contacts as the exception, and it has always worked for me.. 

I had to read the "solution" in the link you posted a couple of times (1st coffee lol), but while you should be able to manually add exceptions to DND, because not all of the calls / messages you want to receive, may not also be your normal "favourites". ie: Hypothetical emergency where you want to receive calls / messages from a hospital or something. 

 

0 Likes
Perma1
Active Level 1
Galaxy S
Well it didn't work!
I had the contacts listed last night, after wiping the cache partition from recovery mode, but this morning they are gone. Maybe it has something to do with the two schedules? I remember on a past phone the "do not disturb" schedule only worked for the first night and I had to add a schedule for every day of the week. This is different, but still a bug in the "do not disturb" mode. It would be nice if these new features actually worked!Screenshot_20230802_081211_Settings.jpgScreenshot_20230802_081336_Settings.jpgScreenshot_20230903_092109_Settings.jpg
0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

And you have tried allowing Favourite Contacts to ignore DND? 

It's always worked for me.

Screenshot_20230802_083321.jpg

Screenshot_20230802_083252.jpg

 

0 Likes