Original topic:

how to answer phone when do not disturb is on

(Topic created on: 05-26-2021 11:21 AM)
Jan52
Active Level 2
Options
Galaxy S

I have do not disturb enabled at night but allow all calls to come through.  The phone will ring, and a small green phone icon appears below the time display, but there is no way to answer the phone.  I can't tap or swipe the icon, nothing happens.  I also can't even unlock the phone until the caller hangs up.  Any suggestions how to fix this?  I have an S20, with Android 11 and One UI 3.1.  There is no problem answering the phone if do not disturb is not on.

21 Comments
Georgine
Moderator
Moderator
Options
Galaxy S

Hi, we request you to restart your device. Once the device is on again, enable Do Not Disturb mode it might be deactivated. Also, check for recent software update.

0 Likes
Jan52
Active Level 2
Galaxy S

Thanks for your response Georgine.  If by "restart" you mean to just reboot it, I have done that numerous times.  If you mean, reset, I'm not that desperate yet 🙂.  I have also checked, and the phone says its software is up to date.  When I was running some errands today, I stopped at a phone store and asked about the problem.  They told me that that is just the way it works.  When a call comes in and the phone is set to "do not disturb", but with calls allowed, it will ring and light a small green icon to say there is an incoming call (which mine does).  Then, you have to login to the phone by double tapping the screen.  This brings up the fingerprint sensor and you can then open the phone and answer the call.  And of course you must do all this within the four rings before the call goes to the answering service.  I asked if the four rings could be increased and was told no, not on the S20.  I'm not sure why the way to answer the phone is different if do not disturb is on compared to when the phone is just sleeping but, apparently it is.  Go figure.  Anyway, I rarely receive calls during the "do not disturb" hours so I'm not going to worry about it anymore and I'll just try and do a quick double-tap, login, and answer, or else let it go to the answering service.  As an aside, my husband has a Note9, running Android 10 and UI version 2, and it exhibits exactly the same behaviour (other than allowing more than 4 rings before going to the answering service).

Davey28fan
Beginner Level 2
Galaxy S

I have the same problem and was just told that this is how Samsung wants the Do Not Disturb to work on these newer phones so that the calls won't interrupt whatever else you are doing on your phone.  I do not like this at all - previous Samsung Galaxy phones worked completely different and I loved the DND feature - it basically blocked all calls not in my contact list - the phone would still light up with calls not in my list, but didn't make a sound...  giving me the option to answer or not...  now I have to keep the DND off just so I can answer a call in a timely fashion...  I do NOT like this new version at all...  but cannot go back to my perfectly good Galaxy because come February it will not work.

h0h0h0
Active Level 7
Galaxy S
If this helps please select it as a solution Screenshot_20210526-163433_Samsung Members.jpg
0 Likes
Jan52
Active Level 2
Galaxy S

Thanks for trying to help.  Please see my response to Georgine's suggestion.

0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

You can add exceptions to Do Not Disturb, in which case DND will not interfere in your ability to answer the phone. 

For example I have set the exception to allow "Favourite" contact to bypass DND.

This is the solution for me, if a Favorite contact calls, or texts me, I probably want to talk to them, but if it's a wrong number, or someone who isn't in my Favourite list, I'm happy to not be disturbed by them.

If this sounds like something you want, just go to settings & Search for "do not disturb" & click on it, on the next screen, click on "exception" and you can allow either contacts or favourites. 

Jan52
Active Level 2
Galaxy S
Thanks for the response. I did try what you suggested but it made no difference. It is now set to allow all calls, not just those in my Contacts list. Still the same behavior. If you check my response to Georgine you'll see that I asked at the phone store and they told me that what the phone is doing is as designed.
RedDogRabbit
Expert Level 5
Galaxy S

I have my DND set to only allow Favorites to bypass DND & it work for me on my S20 Ultra. Are you using any other app to determine the "sleep" state of your phone - ie: Battery Widget Reborn 3rd party app can be used to silence the phone as well as DND.? 

Screenshot_20210527-064637_Settings.jpg

Jan52
Active Level 2
Galaxy S

No other apps that I know of, but thanks for the suggestion.  Note that my phone does allow the calls to come through and the phone rings, there is just no easy way to answer it - no icon to just swipe or tap.  Interesting that your S20 seems to work fine.  When a call comes though, and do not disturb is on, how do you answer it?