Resolved! Solved

Original topic:

PSA: Apps Crashing FIX, Android System Webview crashing apps

(Topic created on: 03-22-2021 03:40 PM)
38148 Views
AW1228
Active Level 3
Options
Galaxy S
 **I noted that my phone ran quite warm under these issues even though I was not charging it. People seem to be reporting the same thing so it is definitely not just coincidence**
 
FYI I've been experiencing multiple apps crashing on my Galaxy S10 but others are reporting it on other Samsung and OnePlus devices. It turns out you need to uninstall Android System Webview from the Google Play Store, which reverts it back to an older (safer) version where we can wait for a more stable update. My phone was perfectly fine about 6 hours ago but began experiencing instant app crashes/crashes on choosing specific options in-app. Would also have several pop-ups saying background app has crashed or is using more battery/data than expected.
 
 Apps others and myself have reported to crash: 
 Samsung Email
 TikTok
 Samsung Pay
 Yahoo Finance
 MyTelus
 OneDrive
 Samsung Members (couldn't even post this before uninstalling Webview)
 SmartThings
 Flipboard Briefing
 Gmail
 IMDB
 Yahoo Mail
 Ring Doorbell
 Mail.com App
 Google App
 Swedbank
 Samsung Calendar
 Evil Apples
 #DRIVE
 Traffix 3D
 HSBC Mobile
 Fitbit
 DuckDuckGo
 Pandora
 Google Maps
 Tumblr
 OkCupid
 Samsung Galaxy Store
 Snapchat
 Samsung Health
 Duolingo
 YouTube
 Facebook
 Imgur
 Outlook
 Google Play Store
 Norton 360
 Accuweather
 LinkedIn
 Amazon
 Upday
 Google Chrome
 Trebuchet Launcher
 Paypal
 Relay
 KIK
 Binance
 iFruit App
 The Score
 ESPN
 Viber
 Discord
 1weather
 Instagram
 Samsung Internet
 Google Authenticator
 Twitter
 Reddit
 (Default) SMS Messenger App
 Hotmail
 All4
 The Irish Times
 Genshin Impact
 Clash of Clans
 Angry Birds
 Questrade
 Wells Fargo
 Venmo
 AOL
 Microsoft News
 Webull
 Google Play Books
 Hilton Honors
 Chase Banking
 Facebook Messenger
 Textra
 TD Bank
 Pokemon Go
 Funimation
 Clash Royale
 Castbox
 MyTesla
 Podcast
 Prime Video
 Audible
 Speed Test
 Quora
 Avast Anti-virus
 Smartnews
 Libby
 Joey
 Convert It
 Tournament Challenge
 Xbox Controller
 TradingView
 Dashlane
 NTV
 Pebble
 Alarm Clock Xtreme
 Canvas
 Microsoft Office Apps
 Bleacher Report
 Team Snap
 CIBC Mobile Banking
Cisco Webex Meetings
 
 Devices others have reported issues on:
 Galaxy A3
 Galaxy A5 2017
 Galaxy A10e
 Galaxy A21s
 Galaxy A50
 Galaxy A51
 Galaxy A70
 Galaxy A71
 Galaxy A90 5G
 Galaxy J7 2017
 Galaxy J8
 Galaxy Tab A 2019
 Galaxy Tab S2
 Galaxy Tab S6 Lite
 Galaxy S7
 Galaxy S7 Edge
 Galaxy S8
 Galaxy S8+
 Galaxy Note 8
 Galaxy S9
 Galaxy S9+
 Galaxy Note 9
 Galaxy S10e
 Galaxy S10
 Galaxy S10+
 Galaxy Note 10+
 Galaxy S20
 Galaxy S20+
 Galaxy S20+ 5G
 Galaxy S20FE
 Galaxy S20FE 5G
 Galaxy S20 Ultra
 Galaxy S20 Ultra 5G
 Galaxy Note 20 Ultra
 Galaxy S21
 Galaxy S21 5G
 Galaxy S21+
 Galaxy S21 Ultra
 Galaxy X Cover Pro
 Galaxy Z Flip
 Galaxy Z Fold 2
 Google Pixel XL
 Google Pixel 2
 Google Pixel 2 XL
 Google Pixel 3
 Google Pixel 3 XL
 Google Pixel 4A
 Google Pixel 4A 5G
 Google Pixel 4 XL
 Google Pixel 5
 OnePlus 5
 OnePlus 5T
 OnePlus 6
 OnePlus 7 Pro
 OnePlus 8
 OnePlus 8T
 OnePlus 8 Pro
 LG G5
 LG G7 ThinQ
 LG G8
 LG V40 ThinQ
 LG Wing
 Huawei Mate 20 Pro
 Oppo 8 Pro
 Oppo R15 Pro
 Motorola Moto Z2 Play
 Motorola Moto X4
 Motorola Razor 2020
 Sony Xperia XZ Premium
 Xiaomi Redmi Note 8 Pro
 Xiaomi Mi 9
 Asus ROG 2
 HTC U11
 Realme 7 Pro
 
 Updating Webview again seemed to bring the problems back for some apps (did not extensively bother to test everything), but I've had no issues with uninstalling Webview to an older version, nor had anymore crashes.
 
 Hopefully this helps someone!
 
 EDIT: For those still struggling to get their phone to work AND have already either disabled/uninstalled Webview, try the same process with Chrome (Webview is powered by Chrome). I only had to uninstall Webview by searching it in the Google Play Store and my problems were immediately resolved.
Resolved!
69 Comments
Ned3
Beginner Level 2
Galaxy S

So I pressed force app when I clicked on webview  and it wont let me disable  it . And at this point my phone cant do anything and I don't know what to do. Does  anybody  have any Info to fix this

0 Likes
AW1228
Active Level 3
Galaxy S
Did you try either restarting your phone or doing a soft reset using the boot menu? It should figure out that ASW shouldn't be disabled at some point and re-enable it
0 Likes
Ned3
Beginner Level 2
Galaxy S

When my apps started crashing  and people  where saying the issue  was android web view. I clicked on the app and clicked  force stop. And force stopping it disabled the app. And now is stuck disabled and my phone is still crashing does any one know how to fix it. I cant go on google play store and fix it. Because when I click on web viewer  it doesn't  allow me to upgrade or uninstall. Even in the settings it's just bugged

0 Likes
TonyGabLei2012
Beginner Level 2
Galaxy S
I can confirm that uninstallling Android System Web view works to stop your apps from crashing. I was unable able to connect to any wifi Network as it would crash before I could enter the password. Any unknown network with password not saved.
0 Likes
RyanKyliuk
Beginner Level 2
Galaxy S
You can add CIBC Mobile Banking to that list (Samsung Galaxy S9)
0 Likes
Mel091998
Beginner Level 2
Galaxy S

Did all of this still not working for my S8+

My android webview is disabled, can't update,  can't enable.  Its grayed out.  Help please

0 Likes
yt8rt
Active Level 4
Galaxy S
I haven't had any of this but that is probably because I have an S6
0 Likes
Geoaugahhh
Beginner Level 2
Galaxy S
Gqlaxy 9+
0 Likes
Geoaugahhh
Beginner Level 2
Galaxy S
Y
0 Likes
SnakeWildFire
Beginner Level 2
Galaxy S
RedAlert/All-google.intergrated/system2put2rashNstartOver.googleSpyingNidenty-theft.globally *Untiuchable* I named him GoogleSpy
0 Likes