Original topic:

S20 FE 5G - wifi dropping after Android 13 One UI version 5.0 forced update

(Topic created on: 12-29-2022 11:01 AM)
2389 Views
Members_bTHNKg4
Active Level 1
Options
Galaxy S

Samsung s20 FE 5G

I was forced to upgrade to Android 13 - One UI Version 5.0

The wifi drops constantly then picks back up. Sometimes it does not pick up again and I have to go into my wifi settings and select my SSID.

 

I have reset the network settings.

I have factory reset the phone as well.

I have reset my router.

It still is happening.

 

All of my other devices have no issues with network drop. It is definitely this update.

 

I was having no issues until this update. I require my phone for wifi calling as I live rurally.

 

Any solutions beyond the factory reset? I'll try 3rd party roll backs if any can point me in that direction. Thanks

19 Comments
theonecid
Expert Level 2
Galaxy S
Android 13 is fine. I know two people with s20 fe and their wifi is fine. Check your modem
Galaxy S

What should I check on my modem? I have no other devices with this issue in my home.

0 Likes
theonecid
Expert Level 2
Galaxy S
Check your wifi settings on your phone and disable Switch to mobile data under Intelligent Wi-Fi if that is enabled.

As for router only thing you can do is power off for a minute then power it back on
0 Likes
Galaxy S

I have just disabled the switch to mobile data option.

 

The issue still persists.

 

I also turned off all other options under Intelligent Wifi.

 

I do have slow internet at home as I'm a rural. It definitely seems to drop with high traffic, streaming videos, or if I share my screen through google home. But it also happens at times randomly, however I can't say whether or not there is higher caching happening when it happens.

 

A friend mentioned turning of wpa2-psk, and just using wpa2.

I have yet to try this.

I am using the ISP's router. If it works normally at work, I may get another router and see if that resolves the issue.

 

For commenters saying it isn't the update, I had no issues and have had the phone for 1.5 years. Immediately following the update the issue started.

0 Likes
theonecid
Expert Level 2
Galaxy S
That's really odd. You shouldn't have to go to such extremes to resolve this. Keep wpa2-psk... also yea it might be your router
0 Likes
Nylah
Moderator
Moderator
Options
Galaxy S

Hi, please follow the steps in the given link to troubleshoot your device and verify if it solves your WiFi connection issue.

https://www.samsung.com/ca/support/mobile-devices/how-to-troubleshoot-a-galaxy-phone-that-wont-conne...

0 Likes
Galaxy S

I followed all of these steps. The issue persists.

0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

Try going to Settings > Connections > WiFi > Manage Network & Click on your WiFi > View More > Click on Mac Address & If it is set to "Randomized", switch it to "Device" & Reboot & Test.

Screenshot_20221229_155308.jpg

Screenshot_20221229_155420.jpg

Galaxy S

I already have it set to Phone Mac. 

The issue persists.

0 Likes