Original topic:

Galaxy S22 Third party apps not working on WIFI 6

(Topic created on: 07-20-2023 07:53 PM)
1620 Views
SolidLemon
Beginner Level 2
Options
Galaxy S

Recently bought my Galaxy S22 and while all my other WIFI connected devices in my home working normally, my phone doesn't load apps. An example is going on Twitter and none of the images will load, not being able to send files to my Google drive, or going on a platform called Connecteam for work, and it not loading the app at all. Youtube, for example, is running perfectly fine on wifi. All apps work fine with mobile data. There were two days last week when the wifi 6 was NOT next to the wifi logo on my phone, and things ran perfectly fine on my phone! There was an update on the phone since then so maybe that messed everything up. Not sure how I accomplished that fix for the short time though. Here is everything I've tried to fix my issue up to now:

-Restarting phone

-Clearing phone cache and apps cache

-Toggle on/off Airplane mode, WIFI, and mobile data

-Unistalling and reinstalling apps

-Resetting network settings

-Unplugging and plugging router back in

-Turning off IPV6 or something on my router settings (Not sure how that all works, does my ethernet need to be plugged in for that change to be made?)

-Updating phone and apps

I'd really like some help with this issue as I've had this phone for only three weeks now. If I could somehow turn off WIFI 6 or do some other real fix that will just allow me to use all my apps normally and efficiently I would appreciate that. I do not enjoy resorting to mobile data for everything I have to do at home with this phone.

0 Likes
4 Comments
RedDogRabbit
Expert Level 5
Galaxy S

I think that it's been reported, that there seems to be an issue with WiFi 6 and the S23 series, but I don't think that I've heard anything about any other Samsung devices?

You could try going to Settings > Connections > WiFi & Click on your WiFi Connection & It's Settings > then "More" and scroll down to "MAC Address type" & if it's set to "Device", change it to "Randomized", or if it's already set to "Device", change it to "Randomized". See that works for you.

Screenshot_20230721_095716.jpg

 

0 Likes
TrinaJ
Beginner Level 2
Galaxy S
I have the SS22+ and have the same issue. I have to turn off my WiFi at home and then my apps load. I can't even operate my Ecobee properly. It's pretty frustrating.
0 Likes
Members_q4PCdeL
Beginner Level 2
Galaxy S

I had the exact same issue with a few apps not loading or being able to watch any live streams.  Resolved this yesterday.  Solution was to turn of the IPV6 on my router settings and set it to IPV4 only.  Now everything works as expected.    Dont know how or why my router settings changed but the issue is now resolved.

0 Likes
DRJ75
Beginner Level 2
Galaxy S

I couldn't send txt messages. 

Cleared cache and data, reset network settings, then rebooted my phone. Cell and wifi signal restored and was able to send text. I'm using g an S22

0 Likes