Original topic:

HDMI-ARC connected Soundbar not turning on

(Topic created on: 02-16-2020 01:21 PM)
13500 Views
Inc0gnit0X
Active Level 1
Options
Others

Current set-up is a Q80R 65inch QLED with a HW-Q90R soundbar connected via HDMI arc. Anynet+ CEC enabled on both soundbar and TV. 

 

After one week of use. Turning on the TV no longer turned on the soundbar and reverted back to TV speakers. If the sound bar is then turned on separately turning off the TV turns off both devices. 

 

I attempted unplugging all cables and powering off. Turning the devices back on, plugging in HDMI cables didn't correct the problem. 

 

I did a TV reset and the TV now turns the soundbar on again. Anyway to prevent having to reset my TV on a weekly basis.

13 Comments
mytech
Expert Level 3
Others
Did you try another cable?
Pupusik
Active Level 7
Others
I agree. Get a quality Cable. not the generic that may have been provided with the soundbar.
check to see if all updates are current for both the TV and soundbar.
0 Likes
Inc0gnit0X
Active Level 1
Others

Worth a try, even though unlikely since a TV reset immediately resolved the issue.

0 Likes
KevinTaylor
Moderator
Moderator
Options
Others

Hi Inc0gnit0X,

 

Before Connecting an Anynet+ Device,

1. Anynet+ (HDMI-CEC) enabled devices must be connected to the TV with an HDMI cable. Some HDMI cables may not support Anynet+ (HDMI-CEC).

2. If the TV remote does not work, set up the device as an Anynet+ (HDMI-CEC) enabled device again.

 

How to enable Anynet+

1. Press the Home button on your remote control to bring up the Eden Menu at the bottom of your screen and then select Settings.

2. Once you are in the Setting Menu, select General, follow by External Device Manager from the middle menu list.

3. Highlight Anynet+ (HDMI-CEC) and press enter on your remote control to turn the feature On/Off.

4. Next, connect an external device using an HDMI cable, and then turn on the device - it will automatically connect to the TV. After the connection is established, you can access the connected device's menu using your TV remote and control the device.

 

If Anynet+ does not work:

  • Make sure the device supports Anynet+.
  • Check the power cord and cable connections of the Anynet+ device.
  • Make sure Anynet+ is turned on (Settings > General > External Device Manager > Anynet+ (HDMI-CEC)).
  • Anynet+ may not function when other functions are active, including Channel search, Smart Hub, Initial Setup, etc.
  • If you have disconnected and then reconnected the HDMI cable, scan for devices again or turn your TV off and on.

Cheers,

KevinTaylor

0 Likes
Inc0gnit0X
Active Level 1
Others

None of this rectified the problem. I found a solution in another forum, not sure why it work.

I had another occurance of the TV not automatically turning on the Q90R soundbar.

 

The solution I found involved selecting the TV as my Input Source and then turning off the TV. When the TV was turned back on the Soundbar turned on.

 

For some reason when the TV is turned on, sometimes it defaults to a different input, a device connected to another HDMI, with prevents Anynet+ from turning on the soundbar. I disabled the TV's memory function to remember the last open app and it now works flawlessly.

 

Glitch software I presume.

aditto
Beginner Level 2
Others

This worked. I changed the TV's input source to TV instead of sound bar and it worked. 

0 Likes
phelko
Beginner Level 3
Others
This worked for me also
0 Likes
PeddlerDavid
Active Level 1
Others

Thank you for sharing your experience.  Sounds like a plausible solution.  I’d like to give it a try.  How do you “disabled the TV's memory function to remember the last open app”?

0 Likes
PeddlerDavid
Active Level 1
Others

Oh, wait.  I think I found it.  Is it:

settings -> general -> smart features-> auto run last app

0 Likes