Original topic:

How to have no default browser for links?

(Topic created on: 04-04-2022 02:32 PM)
6945 Views
SimonHF
Active Level 1
Options
Galaxy S
Just upgraded from Note 10+ to S22 Ultra.

Before / old phone: When clicking on a browser link then the phone had no default and would always ask me which browser app to open the link in this time.

The new phone always just opens the link in the default browser.

How can I configure the new phone to always ask me which browser app to open the link in?
15 Comments
vetman
Active Level 6
Galaxy S
Setting then apps and then default apps
0 Likes
SimonHF
Active Level 1
Galaxy S
Thanks @vetman but that only seems to allow me to set the default apps on the config. However, I want to have no default app... and then always choose the app at run-time instead of using a default app...
SimonHF
Active Level 1
Galaxy S
@RedDogRabbit yes, I have made the same annoying experience as you. Would love to know a fix / work around if there is one... I wonder if there is any kind of app called e.g. "browser chooser" which can be set as the default (because now it seems to force you to pick an app) and then the browser chooser app could then allow the selection of the desired browser app at runtime?
SimonHF
Active Level 1
Galaxy S
One solution which works:

Install app called "Open Link With..." by "Said Tahsin Dane" which has a 4.3 rating and 100K downloads and is free.

Once installed, go to its settings and enable the "Set as browser" feature. Then in the device settings, set it as the default browser!

Now when e.g. clicking on a link embedded in an email then first the "Open Link With..." app opens, and then let's me choose which app to open the link with! 🙂

Note: I had to restart my email app before it would respect my new default browser.

Hope this work around helps somebody else!
Helenna
Moderator
Moderator
Options
Galaxy S

Hi, We will consider it as a feedback.

0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

"circular file"... 🙄 

0 Likes
twmerritt
Beginner Level 2
Galaxy S

I had the same problem when I upgraded my Note 20 Ultra to the S22 Ultra. I found that I could remove the default browser app by doing the following:

  1. Choose an installed browser that could be uninstalled, e.g. DuckDuckGo, and set it as the default browser. (I found out that Google Chrome couldn't be uninstalled, so I didn't choose it.)
  2. Delete the default browser (in my example, DuckDuckGo).
  3. Verify that opening a link in email, for example, asks which app to use...should not have a default.
  4. Re-install the deleted browser, if you still want it.

If you don't want to delete a browser that you currently have installed, install one that you don't want to keep and use it in steps 1-3 above.

This worked for me and hope it works for you.

RedDogRabbit
Expert Level 5
Galaxy S

That works! 👍

ranggaariq
Beginner Level 2
Galaxy S

didnt work for me. after i uninstalled the default browser, i open the link and directly open in other browser :(

0 Likes