Original topic:

Samsung Wallet Canada

(Topic created on: 02-07-2023 06:58 AM)
462 Views
Stedmister
Active Level 4
Options
Galaxy S
I got a popup in my samsung pay app that samsung wallet is coming soon to canada. Anyone know when. The store page says Samsung pay Canada still on the galaxy store. Yet I seen comments that's it is available.i am running 4.9.38 version of samsung pay and my phone is on the support list for samsung wallet.
35 Comments
KOTS21
Active Level 10
Galaxy S
It's available right now clear the Samsung pay app cache and then turn off your phone and then press volume up with the power button at the same time until tout you see another option to clear cache with the volume button go up or down until you see clear cache then press the power button to press yes the turn on your phone and it should be available to download
Stedmister
Active Level 4
Galaxy S
What's the wallet version number?
0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

5.1.97 on my device.

To add to what @KOTS21 said, I'd also Clear Data for Samsung Pay before you Reboot and Wipe Cache from Recovery. 

theonecid
Expert Level 2
Galaxy S
That's not needed. Clearing data will wipe your Samsung Pay stuff. Cache was enough
0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

Clearing Samsung Pay Cache didn't do it for me. 

Clearing Data & Wiping Cache from Recovery worked for me, before that I was getting "update failed". 

 

0 Likes
theonecid
Expert Level 2
Galaxy S
That's because you missed other steps. Clear pay cache, pay framework cache, Galaxy Store cache, system cache and you should be good. It's dumb as hekk that we have to do these steps tho
0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

Ultimately I didn't miss anything, but I started by trying to do the least possible. 

And you're right, it's nonsense that we have to do anything other than Click "update". 

Stedmister
Active Level 4
Galaxy S
This is strange indeed galaxy store says 4.9.38 still i'm running an s9+SmartSelect_20230206-142818_Galaxy Store_69293_1675711698.jpg
0 Likes
RedDogRabbit
Expert Level 5
Galaxy S

Samsung Wallet requires Android 9 or greater to be available for a device.

Your device should be running Android 10 (One UI V2.5), so you should be fine.

Did you try the suggestions above?

  • ie: Clearing Cache & Data for the app?
  • Clear Cache from Recovery? 
  • Could also Clear Cache & Data for the Galaxy Store & Reboot.